Node.js 버전 문의입니다

  • Elevista
    Elevista

    현재 노드 버전이 구버전이라 ES5까지만 되는것 같더라구요
    ES6 문법이 안되는데 혹시 업데이트 해주실 수 있을까요?

    ES6가 표준화가 되었고 편리한 여러가지 요소들이 많이 추가 되었는데
    못쓰고 코딩하려니 불편함이 크네요.
    x => x+1 같은 함수도 못쓰고
    function(x){
    return x+1;
    }
    일일히 이런식으로 쓰려니 불편해요.
    그 외에도 generator function으로
    라인 입력 받는것도 겉보기에 동기식 코드처럼 쓸 수 있는데
    안되는것도 그렇고

    업데이트 해주실 수 있을까요?


    4년 전
2개의 댓글이 있습니다.
  • JongMan
    JongMan

    nodejs 버전 업그레이드했습니다. 확인 부탁드립니다. ^^


    4년 전 link
  • Elevista
    Elevista

    https://www.algospot.com/judge/submission/detail/450107
    아주 잘 되네요~ 감사합니다
    근데 Generator함수 쓰니 시간이 두배로 느는군요 ㅋㅋ


    4년 전 link
  • 정회원 권한이 있어야 커멘트를 다실 수 있습니다. 정회원이 되시려면 온라인 저지에서 5문제 이상을 푸시고, 가입 후 7일 이상이 지나셔야 합니다. 현재 문제를 푸셨습니다.